Как установить Elance Tracker на последний Ubuntu 14.04 (Linux Mint 17)

22 сент. 2014 г., 6:58:27

Elance Tracker

Приложение Elance Tracker использует Adobe Air, а т.к. Adobe остановило поддержку Air для Linux (последняя версия 2.6) - запуск Air приложений на Linux стал проблемой.
В Интернет можно найти множество мануалов (разной степени корректности и работоспособности) о том как решить проблему с установкой Air на Linux (такие как линкование libgnome-keyring.so и т.д.), но с каждым новым релизом Ubuntu совместимость всё меньше.

В Ubuntu 13.10 долгое время я вобще не мог найти рабочего способа для установки Adobe Air. Только способ от tkalin.com помог это сделать.

  • Вот вся установка одним скриптом. Сохраните его в файл, например, install_adobe_air.sh
#!/bin/bash
apt-get install libgtk2.0-0:i386 libstdc++6:i386 libnss3-1d:i386 lib32nss-mdns libxml2:i386 libxslt1.1:i386 libcanberra-gtk-module:i386 gtk2-engines-murrine:i386
cd /tmp
apt-get download libgnome-keyring0:i386
dpkg-deb -R libgnome-keyring0_3.8.0-2_i386.deb gnome-keyring
cp gnome-keyring/usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/i386-linux-gnu/
ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/i386-linux-gnu/libgnome-keyring.so.0
ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
wget http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRInstaller.bin
chmod a+x AdobeAIRInstaller.bin
./AdobeAIRInstaller.bin
rm ./AdobeAIRInstaller.bin
rm /usr/lib/libgnome-keyring.so.0
rm /usr/lib/libgnome-keyring.so.0.2.0
  • Сделайте его исполняемым sudo chmod a+x install_adobe_air.sh
  • И запустите sudo ./install_adobe_air.sh (в ходе процесса появится графическое окно установки Abode Air )
  • Потом скачайте Elance Tracker для Linux и установите самым обычным способом

Опробовано со следующими дистрибутивами :

  • Ubuntu 13.10, 14.04
  • Linux Mint 15, 16, 17
  • Elementary OS Luna 0.2, 0,3
comments powered by Disqus
Евгений
Кузьминов "iJackUA"
Web Team Lead
в MobiDev (Харьков, Украина)
Code in Ruby and Elixir, but still love PHP. Explore ES6 and Vue.js. Explore databases, use Ubuntu and MacOS, think about IT people and management

Заметки


Have you noticed? Nowadays nobody is doing a New JavaScript framework 😧 These days are over... Everybody is doing their brand new blockchain 😜